package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div [^>]+>([^<]+)<\/div>`)
var str = `<div class="1">Получить</div>Пропустить всё<div class="2">Получить</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}