$re = '/([aA].*){2,}/m';
$str = 'banana #True
pinepple #True
Animal Kingdom #True
A is foraa apple #True';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);