re = /([aA].*){2,}/m
str = 'banana #True
pinepple #True
Animal Kingdom #True
A is foraa apple #True'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end