#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{4})-(\d{2})-(\d{2})(?:[T ](\d{2}):(\d{2}):(\d{2})(?:\.(\d{0,7}))?(?:([+-])(\d{2}):(\d{2}))?)?"
Local $sString = "2020-01-01T00:00:00.000000+04:07" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2020-01-01 00:00:00.000000-04:07" & @CRLF & _
"" & @CRLF & _
"2020-01-01 00:00:00.000000Z" & @CRLF & _
"" & @CRLF & _
"2020-01-01" & @CRLF & _
"" & @CRLF & _
"2020-01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")