re = /(\d{4})-(\d{2})-(\d{2})(?:[T ](\d{2}):(\d{2}):(\d{2})(?:\.(\d{0,7}))?(?:([+-])(\d{2}):(\d{2}))?)?/m
str = '2020-01-01T00:00:00.000000+04:07
2020-01-01 00:00:00.000000-04:07
2020-01-01 00:00:00.000000Z
2020-01-01
2020-01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end