package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})-(\d{2})-(\d{2})(?:[T ](\d{2}):(\d{2}):(\d{2})(?:\.(\d{0,7}))?(?:([+-])(\d{2}):(\d{2}))?)?`)
var str = `2020-01-01T00:00:00.000000+04:07
2020-01-01 00:00:00.000000-04:07
2020-01-01 00:00:00.000000Z
2020-01-01
2020-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}