import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})-(\\d{2})-(\\d{2})(?:[T ](\\d{2}):(\\d{2}):(\\d{2})(?:\\.(\\d{0,7}))?(?:([+-])(\\d{2}):(\\d{2}))?)?";
final String string = "2020-01-01T00:00:00.000000+04:07\n\n\n"
+ "2020-01-01 00:00:00.000000-04:07\n\n"
+ "2020-01-01 00:00:00.000000Z\n\n"
+ "2020-01-01\n\n"
+ "2020-01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}