#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\${([^}]+)}"
Local $sString = "<!-- This ad was designed by Creative Studio: ; Production: Gen; Format: Express, Dynamic Retargeting; --><iframe src="https://example.com/DRT/100x90/index.html?&text_gwd-span-13vm=${drt_title}&text_gwd-p-1n7w=${drt_price}&image_productimage=${drt_image}&click=${drt_click}" width=728 height=90 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no bordercolor="#000000"></iframe>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")