import Foundation
let pattern = #"\${([^}]+)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"<!-- This ad was designed by Creative Studio: ; Production: Gen; Format: Express, Dynamic Retargeting; --><iframe src="https://example.com/DRT/100x90/index.html?&text_gwd-span-13vm=${drt_title}&text_gwd-p-1n7w=${drt_price}&image_productimage=${drt_image}&click=${drt_click}" width=728 height=90 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no bordercolor="#000000"></iframe>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)