$re = '/\${([^}]+)}/m';
$str = '<!-- This ad was designed by Creative Studio: ; Production: Gen; Format: Express, Dynamic Retargeting; --><iframe src="https://example.com/DRT/100x90/index.html?&text_gwd-span-13vm=${drt_title}&text_gwd-p-1n7w=${drt_price}&image_productimage=${drt_image}&click=${drt_click}" width=728 height=90 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no bordercolor="#000000"></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);