const regex = /\${([^}]+)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\${([^}]+)}', 'gm')
const str = `<!-- This ad was designed by Creative Studio: ; Production: Gen; Format: Express, Dynamic Retargeting; --><iframe src="https://example.com/DRT/100x90/index.html?&text_gwd-span-13vm=\${drt_title}&text_gwd-p-1n7w=\${drt_price}&image_productimage=\${drt_image}&click=\${drt_click}" width=728 height=90 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no bordercolor="#000000"></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}