package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)\([^()]*\)`)
var str = `Hello my name is (john) (doe) (bob)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}