re = /^(.*)\([^()]*\)/m
str = 'Hello my name is (john) (doe) (bob)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result