$re = '/^(.*)\([^()]*\)/m';
$str = 'Hello my name is (john) (doe) (bob)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;