use strict;
my $str = 'Hello my name is (john) (doe) (bob)';
my $regex = qr/^(.*)\([^()]*\)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";