#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)REF\.: (.+?)$"
Local $sString = "<div class="productDescription" style="overflow: hidden; display: block;">" & @CRLF & _
"Black Tshirt" & @CRLF & _
"<br>" & @CRLF & _
"<br>" & @CRLF & _
"REF.: V23T87C88EC" & @CRLF & _
"<br>" & @CRLF & _
"<br>" & @CRLF & _
"COMPOSIÇÃO:" & @CRLF & _
"<br>" & @CRLF & _
"90% Poliamida" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")