re = /REF\.: (.+?)$/m
str = '<div class="productDescription" style="overflow: hidden; display: block;">
Black Tshirt
<br>
<br>
REF.: V23T87C88EC
<br>
<br>
COMPOSIÇÃO:
<br>
90% Poliamida
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end