package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)REF\.: (.+?)$`)
var str = `<div class="productDescription" style="overflow: hidden; display: block;">
Black Tshirt
<br>
<br>
REF.: V23T87C88EC
<br>
<br>
COMPOSIÇÃO:
<br>
90% Poliamida
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}