import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "REF\\.: (.+?)$";
final String string = "<div class=\"productDescription\" style=\"overflow: hidden; display: block;\">\n"
+ "Black Tshirt\n"
+ "<br>\n"
+ "<br>\n"
+ "REF.: V23T87C88EC\n"
+ "<br>\n"
+ "<br>\n"
+ "COMPOSIÇÃO:\n"
+ "<br>\n"
+ "90% Poliamida\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}