using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1(?!.*[23456789])|2(?!.*[3456789])|3(?!.*[456789])|4(?!.*[56789])|5(?!.*[6789])|6(?!.*[789])|7(?!.*[89])|8(?!.*[9])|9(?!.*[9])";
string input = @"26418917853216548456418745445321";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}