import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1(?!.*[23456789])|2(?!.*[3456789])|3(?!.*[456789])|4(?!.*[56789])|5(?!.*[6789])|6(?!.*[789])|7(?!.*[89])|8(?!.*[9])|9(?!.*[9])";
final String string = "26418917853216548456418745445321";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}