const regex = /1(?!.*[23456789])|2(?!.*[3456789])|3(?!.*[456789])|4(?!.*[56789])|5(?!.*[6789])|6(?!.*[789])|7(?!.*[89])|8(?!.*[9])|9(?!.*[9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1(?!.*[23456789])|2(?!.*[3456789])|3(?!.*[456789])|4(?!.*[56789])|5(?!.*[6789])|6(?!.*[789])|7(?!.*[89])|8(?!.*[9])|9(?!.*[9])', 'gm')
const str = `26418917853216548456418745445321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}