using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.)([^.]+)(?:\.(?:co\.uk|ac\.us|[^.]+(?:$|\n)))";
string input = @"m.google.com
m.docs.google.com
www.someisotericdomain.innersite.mall.co.uk
www.ouruniversity.department.mit.ac.us
www.somestrangeurl.shops.relevantdomain.net
www.example.info";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}