$re = '/(?<=\.)([^.]+)(?:\.(?:co\.uk|ac\.us|[^.]+(?:$|\n)))/';
$str = 'm.google.com
m.docs.google.com
www.someisotericdomain.innersite.mall.co.uk
www.ouruniversity.department.mit.ac.us
www.somestrangeurl.shops.relevantdomain.net
www.example.info';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);