#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[^\p{L}\p{N}]+|[^\p{L}\p{N}]+$"
Local $sString = "__Markdown__" & @CRLF & _
"" & @CRLF & _
"** Intro **" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"** Tort __ illa **" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")