re = /^[^\p{L}\p{N}]+|[^\p{L}\p{N}]+$/m
str = '__Markdown__
** Intro **
** Tort __ illa **
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end