package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\p{L}\p{N}]+|[^\p{L}\p{N}]+$`)
var str = `__Markdown__
** Intro **
** Tort __ illa **
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}