$re = '/^[^\p{L}\p{N}]+|[^\p{L}\p{N}]+$/um';
$str = '__Markdown__
** Intro **
** Tort __ illa **
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);