package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^if.*\R+(?:^[\t ]+.*\R+)*?^[\t ]+test\.check\(\).*\R?`)
var str = `if global_var:
fizz()
test.buzz()
test.check()
bang()
bop()
would match but not any of the following
fizz()
test.buzz()
test.check()
bang()
bop()
if global_var:
fizz()
test.buzz()
bang()
bop()
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}