import re
regex = re.compile(r"(?m)^if.*\R+(?:^[\t ]+.*\R+)*?^[\t ]+test\.check\(\).*\R?")
test_str = ("if global_var:\n"
" fizz()\n"
" test.buzz()\n"
" test.check()\n"
" bang()\n"
" bop()\n\n"
"would match but not any of the following\n\n"
"fizz()\n"
"test.buzz()\n"
"test.check()\n"
"bang()\n"
"bop()\n\n"
"if global_var:\n"
" fizz()\n"
" test.buzz()\n"
" bang()\n"
" bop()\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")