import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^if.*\\R+(?:^[\\t ]+.*\\R+)*?^[\\t ]+test\\.check\\(\\).*\\R?";
final String string = "if global_var:\n"
+ " fizz()\n"
+ " test.buzz()\n"
+ " test.check()\n"
+ " bang()\n"
+ " bop()\n\n"
+ "would match but not any of the following\n\n"
+ "fizz()\n"
+ "test.buzz()\n"
+ "test.check()\n"
+ "bang()\n"
+ "bop()\n\n"
+ "if global_var:\n"
+ " fizz()\n"
+ " test.buzz()\n"
+ " bang()\n"
+ " bop()\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}