#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "a ([0-9]+).*"
Local $sString = "a 10 b 12"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)