use strict;
my $str = 'a 10 b 12';
my $regex = qr/a ([0-9]+).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";