$re = '/a ([0-9]+).*/';
$str = 'a 10 b 12';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;