package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`a ([0-9]+).*`)
var str = `a 10 b 12`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}