#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alnum:]*.]+[^[:space:]]*[[:space:]]+@"
Local $sString = "*.info;mail.none;authpriv.none;cron.none /var/log/messages" & @CRLF & _
"authpriv.* /var/log/secure" & @CRLF & _
"mail.* -/var/log/maillog" & @CRLF & _
"cron.* /var/log/cron" & @CRLF & _
"*.emerg :omusrmsg:*" & @CRLF & _
"auth.*,authpriv.* @loghost.example.com:10514 # One "@" means UDP" & @CRLF & _
"*.* @@loghost.example.com # Two "@" means TCP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")