re = /^[[:alnum:]*.]+[^[:space:]]*[[:space:]]+@/m
str = '*.info;mail.none;authpriv.none;cron.none /var/log/messages
authpriv.* /var/log/secure
mail.* -/var/log/maillog
cron.* /var/log/cron
*.emerg :omusrmsg:*
auth.*,authpriv.* @loghost.example.com:10514 # One "@" means UDP
*.* @@loghost.example.com # Two "@" means TCP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end