#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]*\.?[0-9]+"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"105" & @CRLF & _
"-1" & @CRLF & _
"-12" & @CRLF & _
"-105" & @CRLF & _
"+5" & @CRLF & _
"" & @CRLF & _
"5.6e12" & @CRLF & _
"-5.30e+3" & @CRLF & _
"-.8E-3" & @CRLF & _
"-3.1267" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")