$re = '/^[-+]?[0-9]*\.?[0-9]+/m';
$str = '1
12
105
-1
-12
-105
+5
5.6e12
-5.30e+3
-.8E-3
-3.1267
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);