import re
regex = re.compile(r"^[-+]?[0-9]*\.?[0-9]+", flags=re.MULTILINE)
test_str = ("1\n"
"12\n"
"105\n"
"-1\n"
"-12\n"
"-105\n"
"+5\n\n"
"5.6e12\n"
"-5.30e+3\n"
"-.8E-3\n"
"-3.1267\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")