// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?[0-9]*\.?[0-9]+").unwrap();
let string = "1
12
105
-1
-12
-105
+5
5.6e12
-5.30e+3
-.8E-3
-3.1267
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}