import Foundation
let pattern = #"(\d+[-|/]\d+[-|/]\d+\s\S+)\s+(\w+)\s+([^:]+):\s+(.+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2023-02-23 19:27:02 WARN SparkDriver(183): 是否使用testGo模式?false testGo模式下忽略命令行-b参数.
2023-02-23 19:27:02 WARN SparkDriver(359): 命令行参数(cmdOption):{a=de_boardHistory, b=boardHistory, g=[loadToAdb=false, upsert=true, etlDate=20230222], w=null}
2023-02-23 19:27:02 INFO ConfigOption(111): 加载本地配置文件(local.config),覆盖项目配置
2023-02-23 19:27:02 INFO ConfigOption(78): 提取命令行(cmdOption)相同key,覆盖项目配置
2023-02-23 19:27:02 WARN SparkDriver(183): 项目配置(configOption)重要参数:{cluster=true, test=false, projectName=ATLAS-ETL...
23/02/23 20:03:25 WARN [Driver] SparkUtil: /---------------------------------------*
23/02/23 20:03:25 WARN [Driver] SparkUtil: * SparkDiver *
23/02/23 20:03:25 WARN [Driver] SparkUtil: * <spark-2.4.7, scala-2.11> *
23/02/23 20:03:25 WARN [Driver] SparkUtil: *---------------------------------------*/
23/02/23 20:03:25 INFO [Driver] SparkUtil: init spark...
23/02/23 20:03:25 INFO [Driver] SparkUtil: localTest: false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)