package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)`)
var str = `static public void main(String[] args)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}