re = /(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/m
str = 'static public void main(String[] args)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end