// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)").unwrap();
let string = "static public void main(String[] args)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}