package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?i)Item.*?Item`)
var str = `Item here is some important text Item
Here is no important text
Item here is some additional important text Item`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}