re = /(?s)(?i)Item.*?Item/
str = 'Item here is some important text Item
Here is no important text
Item here is some additional important text Item'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end