$re = '/(?s)(?i)Item.*?Item/';
$str = 'Item here is some important text Item
Here is no important text
Item here is some additional important text Item';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);