const regex = /(?s)(?i)Item.*?Item/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?i)Item.*?Item', 'g')
const str = `Item here is some important text Item
Here is no important text
Item here is some additional important text Item`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}