using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(AX|C)\d+$";
string input = @"AX5
AX10
AX10asas
AX25
AX50
AX100
B25
B50
B100
B150
B200
C5
C10
C20
C50
C100
E5
E10
E25
CXX25
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}